Jump to content

OpenGL Lighting not the same as in video


Recommended Posts

So I just watch this video on the update of Openrct2 OpenGL Lighting. This is the video 

So I decided to turn the OpenGL Lighting option and it is not even the same as shown. The video shows RCT2 looking like a 3D game yet it doesn't change anything when I change the Drawing Engine to OpenGL. Why is this happening?

 

image.thumb.png.9d440a2d5542c81097e89cde7f42e60f.png

image.thumb.png.ddb9d453d1a3f67ecea6f5ebe9292d0f.png

It looks nothing as shown in the video

 

Link to comment

You've only changed the drawing engine. To get lights and shadows, you need to enable day/night cycling and light effects in the second tab as well. Still those aren't the same (and require hardware rendering rather than OpenGL). The footage shown in the video never made it into the official codebase.

  • Like 2
  • Informative 1
Link to comment
On 09/09/2022 at 19:13, UnknownKid said:

 I decided to turn the OpenGL Lighting option and it is not even the same as shown. The video shows RCT2 looking like a 3D game yet it doesn't change anything when I change the Drawing Engine to OpenGL. Why is this happening?

 

Because it's not the same - the OpenGL lighting shown in that video was a prototype that was never made it into the game. There are some lighting effects included in the game which you can enable in the options, but they work quite differently and won't look as nice. I don't know if source code for the prototype lighting was ever made available, but if it is, it'd take quite a lot of work to update it to work with the current version of OpenRCT2, a lot has changed since 2017.

Changing the drawing engine to OpenGL doesn't itself change how the game looks, it just means that OpenRCT2 will use OpenGL to accelerate the drawing which will usually improve performance. However, if you want to use the lighting effects you need to have your drawing engine set to "Software (hardware display)" - they don't work in OpenGL mode.

  • Like 1
Link to comment
  • 2 weeks later...

one workaround is to install reshade from reshade.me which can add some flair to openrct2 in opengl mode, HOWEVER, every time the game updates (which can be 3 or 4 times a day on develop) you have to reinstall reshade, which is why I don't use it (I only play on develop)

 

1557772217_openrct22022-09-2703-34-02.thumb.png.d947e5a34fdbbf09b41185b57f9c8c86.png

Edited by 733737
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...