Jump to content
OpenRCT2

message: "openrct.exe - Entry Point Not Found" (OPENRCT2 NOT WORKING)


Recommended Posts

I had been without internet access for weeks before today and the openrct2 version i was using during that time worked well enough... and i could play(though it did freeze once in a while before loading). But now, today after my launcher has installed the latest "develop" version... i cannot open openrct2 at all, i get this message: openrct2.exe - Entry Point Not Found (x) The procedure entry point K32GetModuleFileNameExW could not be located in the dynamic link library KERNEL32.dll after pressing the "play" button from the launcher.5a1c724b4c6a7_openrct2kernelerror.thumb.jpg.f25ff7733587ca43d678d292e2b99a27.jpg

I am completely unable to open the game, any help???

Link to post

Sounds like you're running a Windows OS that is no longer supported by Microsoft. I'm surprised you were able to run previous versions at all. Most off all I suggest upgrading your OS. If for some reason you really don't want to do that, try downloading an older version of the game that you know worked before, and don't update it (so don't use the launcher). Do you remember which version you were running first?

  • Like 1
Link to post

If it worked 4 weeks ago, you can just select the stable build in the launcher. Otherwise you could go through the history of AppVeyor manually to find a build from 4+ weeks ago: https://ci.appveyor.com/project/IntelOrca/openrct2-ject9/history

Look for commits saying "Merging Localization into develop", which are basically nightly builds. Any other builds may be from pull requests that still had to be merged at that point, and may miss some functionality. Then select your platform (x86 or x64), go to artifacts on the right, and download the zip. Extract the contents into your Docuements/OpenRCT2 folder, and you should be able to play by opening OpenRCT2/bin/openrct2.com.

  • Like 1
Link to post

I am not able to figure this out...   I went to: https://ci.appveyor.com/project/IntelOrca/openrct2-ject9/build/0.1.2.11657/job/q0nt4nbfuvh9ohln/artifactsi

and saw :

Zip archive
6 MB
OpenRCT2-portable
Zip archive
13 MB
OpenRCT2 debug symbols
-Which one do i download? -I downloaded all three, and extracted "OpenRCT2-0.1.1-linux-i686.tar.gz"  to Docuements/OpenRCT2, and i am still getting the same error..  did you actually mean"OpenRCT2/bin/openrct2.com." or ".exe"  ????
Anyway this doesn't seem to be working. I reported my issue at github so maybe i'll wait to see if future updates don't have this error.
The developers at github are supposed to be addressing the problem, but they have not fixed it yet.
Oh and also, at github, they suggested i upgrade to "linux" but i don't trust that linux will be familiar to me and prefer not to install it.
Edited by joshmarsilio
Link to post

As we already said on Github, it was caused by Discord integration. Janisozaur actually sent in a patch to allow for Vista support, which has been merged, but we need to update our dependencies. After that, the game should work on Vista again.

But really, you shouldn't expect programs to support Windows Vista anymore. Microsoft stopped supporting it and it was never popular anyway.

  • Like 1
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...