Jump to content
OpenRCT2
grknats

Why i havent many display resolutions in the game?

Recommended Posts

hi everybody, firstly i wanna say,this mod is amazing really! well done! im so glad with such amazing mode for this game...

 

i looked settings in the game but i see just 2 options for change resolution... it made me sad actually.. cuz first option its so far (1280 x 768), second option so near (800 x 480 ) , my eyes will break:)) please add to next patch.. im waiting or maybe we can change but i couldnt find anything...

i would like to set display resolution that  1024 x 768 or 1024 x 600  for example or something like that (could be nearby) i would like to see 4-5 options in the display resolutions... thanks everybody! :)

 

Share this post


Link to post

You can play in borderless mode, and use the scale to get the size you want. To get more control over how the number changes, you can edit the config file in your OpenRCT2 documents folder manually.

  • Like 2

Share this post


Link to post

we are chattting with u @Broxzier  already thanks a lot but i would like to say another friends , it doesnt work.... 

i cant change my resolution maybe another friends knows some info about that? thanks guys 

im trying to change dipslay resolution in the game but i couldnt change , may somebody try change to resolution? 

 

oh i see just now he is devepoler:)) so if he doesnt know , who knows this settings?:)) we hope we will fix it and im waiting for new patches for more options in the game....

Edited by grknats

Share this post


Link to post

From the screenshot you sent me it looks like you're on a few months old version. Try switching to the develop branch, and check the options screen again.

  • Like 1

Share this post


Link to post

hi @Broxzier again,

 

i downloaded this " OpenRCT2-0.0.5.0-develop-1dd2751-windows-x64" in 8 october , i think its not old version, isnt it?

 

maybe i should download stable 0.0.4 version? u mean that?

 

 

524cafa54c484d4db4dc0633c003e3ee.png

Share this post


Link to post

i downloaded stable version 0.0.4 and i installed but still doesnt work i cant change resolution there has just 2 options :(

maybe i set wrong in config.ini ?

i change that 1024 x 600 but it doesnt change when i looked in the game...

 

sdswdw.jpg

Share this post


Link to post

Download one from the Recent downloads list instead of stable, or even better use the Launcher. That way you'll stay updated all the time.

The following screenshot is made with borderless fullscreen mode and a scale of 1.65, on a 1920x1080 screen.

Six Flags Magic Mountain 2016-12-09 20-09-00.png

  • Like 1

Share this post


Link to post
1 minute ago, Broxzier said:

Download one from the Recent downloads list instead of stable, or even better use the Launcher. That way you'll stay updated all the time.

The following screenshot is made with borderless fullscreen mode and a scale of 1.65, on a 1920x1080 screen.

Six Flags Magic Mountain 2016-12-09 20-09-00.png

okay now i download that( last update)  0.0.5.0 build d1d6be0

 

i see u changed window scale factor:) it makes worse to display quality? isnt it? 

if i set 1280 x 768 to display resolution with window scale factor 1.0 , i see bad quality display when i changed window scale factor 1.25...  little changed if we use window scale factor, this settings looks like zoom :) i install now last update i will look again window scale factor... 

Share this post


Link to post

if i changed 1,25 , display quality made blurred..

if i changed 1,0 , quallity is better and looks HD as u see:) i see we cant do nothing.. but its ok i will play with 1,25 :) there is no way

and i would like to say we wanna new languages! for example Turkish! i saw a lot of languages but i couldnt see Turkish :(

sorry for my flood messages

dddd.jpg

Share this post


Link to post

Window scale factor does exactly what it says - it scales the screen, which will make it appear more blurred. It is intended for users with high resolution displays, who find that the UI is too small when displayed 1:1. If it looks blurry to you, I would not use it.

The display resolutions shown are those reported by your OS via SDL_DisplayMode - they're the resolutions that your monitor supports. It looks like OpenRCT2 does not by default show resolutions whose aspect ratio differs from your monitor's native resolution. You may be able to get more choice by changing this setting but I can't figure out exactly where you change it (or if you can do so without rebuilding the game). If your desired resolution isn't shown you can run the game in windowed mode rather than fullscreen - then the resolution setting is ignored and you can resize the window however you want.

If you want to add a new translation to the game, check out the localisation repository. To add a new language, you will need this file, which contains all the strings used by the game (note: this only contains strings used by the base game and not those found in object files- these cannot be translated into languages not supported by vanilla until a new file format is implemented).

  • Like 1

Share this post


Link to post
10 hours ago, X7123M3-256 said:

Window scale factor does exactly what it says - it scales the screen, which will make it appear more blurred. It is intended for users with high resolution displays, who find that the UI is too small when displayed 1:1. If it looks blurry to you, I would not use it.

The display resolutions shown are those reported by your OS via SDL_DisplayMode - they're the resolutions that your monitor supports. It looks like OpenRCT2 does not by default show resolutions whose aspect ratio differs from your monitor's native resolution. You may be able to get more choice by changing this setting but I can't figure out exactly where you change it (or if you can do so without rebuilding the game). If your desired resolution isn't shown you can run the game in windowed mode rather than fullscreen - then the resolution setting is ignored and you can resize the window however you want.

If you want to add a new translation to the game, check out the localisation repository. To add a new language, you will need this file, which contains all the strings used by the game (note: this only contains strings used by the base game and not those found in object files- these cannot be translated into languages not supported by vanilla until a new file format is implemented).

 if it looks blurry for me, what should  i do? do u think change my main resolution on my laptop? i use on my laptop now 1280 x 768. maybe game shows resolutions to me what i set main resolution on my laptop? for example if i set 1024 x 600 , i will see the same settings as main resolution? i mean game settings depends to main resolution maybe

 

 

gtgtgt.jpg

Share this post


Link to post

Your screen is probably already blurry because you're not using the pixels on a 1:1 ratio. I'm not sure what you want to achieve now though. If you want to select a different resolution that is not blurry, then simply keep the scale on 1, and play in fullscreen borderless, but if you think that's too small you have to play with the scale, or play in fullscreen with the settings your computer supports.

Share this post


Link to post
2 hours ago, Broxzier said:

Your screen is probably already blurry because you're not using the pixels on a 1:1 ratio. I'm not sure what you want to achieve now though. If you want to select a different resolution that is not blurry, then simply keep the scale on 1, and play in fullscreen borderless, but if you think that's too small you have to play with the scale, or play in fullscreen with the settings your computer supports.

okay thanks for everything bro im playing with good quality:)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...