Jump to content
OpenRCT2

Cannot get RCT1 to work after new install.


Recommended Posts

I have used OpenRCT2 (windows 64) before with both rct1 & 2 (with all expansions).  I recently upgraded my PC (the original RCT files were all on an external hard drive) and have reinstalled the latest stable version of OpenRCT2.  It picked up RCT2 without a problem and works fine BUT, when I try and select the path to RCT1 it said it wasn't installed.  So I reinstalled the entire thing from scratch (including both expansion packs).  When I try and add the directory it says I have to add the "csg1i.dat" file from the CD.  After I add the file and try again it says "The specified path contains a RollerCoaster Tycoon 1 installation but this version is not suitable.  Open RCT2 needs a Loopy Landscapes or RCT Deluxe install in order to use RollerCoaster Tycoon1 assets."

I have installed and tested RCT1 and it works.  The original won't run on win10 but when Added Attractions and Loopy Landscapes are installed it works fine.  These installs are from the original CDs of the game (yes I'm that old), not purchased downloads.  Unless something has been changed in OpenRCT2 I don't understand why it won't work because it's the exact same install that I used on my last PC.  Has anyone got any suggestions on how to fix this or am I off to GOG to spend a couple of bucks?

Cheers.

I have since uninstalled OpenRCT2 v0.3.2 and installed the version I was running before (v0.1.2-develop-c4f3643-windows-x64) and now EVERYTHING IS WORKING, although there are a number of bugs I'm sure have been fixed in future versions.  I'm curious to know what changed to make my ORIGINAL CD version of RCT1 with Added Attractions and Loopy Landscapes stop working and if it can be fixed.  I'm no fan of "rent a copy" and I would have thought the CDs would have been the definitive versions.  Would love to hear from the devs on this.

Edited by ChookFowler
Further information
Link to post

I have updated OpenRCT2 incrementally to the current version and it was still working.  One thing I did notice while upgrading, at one stage the intro music completely stopped playing.  I checked and tried every option (including random) but it never came back but selecting RCT1 on the title music gave the error "css50.dat not found add css17.dat".  Once I tried to change any option that had anything to do with RCT1 I was getting the red error messages but the game continued to work with RCT1.  I deleted the RCT1 installation path and tried to change it which crashed the game.  Now the RCT1 installation path is gone (from the options window) and every time I select it the game crashes. 

Now I'm off to start again and find out at which version the problems start.

One thing I have already learned.  If you uninstall OpenRCT2 and reinstall an earlier version, trying to add RCT1 still crashed the game.  I realized the uninstall does NOT remove the directories/files in the documents folder.  I also discovered, when I got the thing running again on v0.1.2-develop-c4f3643-windows-x64 that RCT1 was indeed missing css17.dat (red error message above).  Once again I now have a running version in which everything appears to be working.

Edited by ChookFowler
further information
Link to post

I have discovered that no matter what build you are on, if you try and change the RCT1 installation path the program crashes.  Perhaps lock the field after setting it.  Otherwise I have jumped straight to v0.3.2 and everything else seems to be working great.

I hope it helps anyone else out that has the same problems getting it running from the CD version as I did.

I'll also add any relevant info I come across in future here, as I'm an RCT1 fan (original not expansion packs).

Cheers.

Edited by ChookFowler
further information
  • Dislike 1
Link to post

There are devs who really care about RCT1 compatibility and they're still working on it, see #13614 and #13636.

When I try to change the RCT1 directory, the game does not crash. I don't know what could have caused the crash on your system, but if it remains a problem please open an issue on GitHub and there might be some devs willing to help you.

Link to post
4 hours ago, ChookFowler said:

I recall from years ago that the devs have no interest in anything RCT1 related, so this thread has been for information purposes only and I hope it helps anyone else out that has the same problems getting it running from the CD version as I did.

Sure, we introduced the option to load up SV4/SC4 files (which RCT2 could not do), the RCT1 theme, the RCT1 title sequences, the RCT1 scenario selector, the RCT1 land types, the RCT1 powered launch mode and several other RCT1 compatibility things, but we "have no interest in anything RCT1 related". Unbelievable. How about you stop spreading such blatantly false nonsense?

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...