Jump to content

Extracting Archive Issues MacOS


Recommended Posts

Good evening!

Totally new to this entire concept, but as I found out RCT2 would be playable on my Apple computer I thought I'd give it a try.

So I downloaded the OpenRCT2 installer and (after trying the method via GOG, POM and all manner of other programs and files that had to be installed, did not work) tried to open the demo .exe. I have unpacked the .exe to a location, /User/myname/documents/extractedfileshere, downloaded the launcher (via a link that led me to GitHub - as the one I got via the QuickStart brakes down on me as I selected a wrong directory the first time round and it will not stop crashing now) and tried to make it work. Tried both the .exe and .zip, by the way. I got messages saying there was problems "extracting the archive", later even saying "no download available". And I also tried to put the map (which is called RollerCoasterTycoon2TTP_EN) in my applications folder - still nothing. Am I missing something here?

 

Thanks in advance!

Link to post

Same problem here, showed up last night. I'm not new to the game and it worked just fine the past couple of weeks. I think the builds have issues.

 

macOS 10.15.4

Edited by Yoshi
Link to post

There was an outage on openrct2.org, which is now resolved.

22 hours ago, GvLiechtenstein said:

So I downloaded the OpenRCT2 installer and (after trying the method via GOG, POM and all manner of other programs and files that had to be installed, did not work) tried to open the demo .exe.

Er, why are you trying to install the Windows version of OpenRCT2 on your Mac? That makes little sense, as we have a native Mac version. Same applies to the Launcher.

What you need to do is:

  1. Download the launcher
  2. Run it
  3. Start OpenRCT2
  4. When asked for the RCT2 files, point it to the RollerCoasterTycoon2TTP_EN folder (which you can place anywhere you like).

That should be it.

Link to post

Good morning!

Thanks for your reply. Just to be clear, this is what I have done so far:

1. Downloaded the MacOS-launcher via both GitHub and the quickstart-introduction on the website. The one I got via GitHub shows the 'play' button but crashes immediately after clicking that, the other one just crashes immediately.

2. Downloaded the demo files (both .zip and .exe, which give the same result when unpacked).

3. Startet OpenRCT2 and pointed it to the files I unpacked.

So, as already stated at my first point: it just crashes constantly. The OpenRCT2 I downloaded via GitHub gave al sorts of errors yesterday (hence the title of this thread), but today it shows the play button just fine. However, it crashes after clicking that button... So am I missing something here?

Link to post

Please edit your messages instead of triple-posting. (This is basic forum etiquette.)

I am not sure this is a launcher bug to begin with, considering it just downloads ZIPs from openrct2.org and has trouble extracting them because they are corrupt.

Link to post

Thanks for the helpful reminder, Gymnasiast!  Last forum I was active in shutdown around 2010.

So someone posted corrupt .ZIP files?  Have the files been fixed?

EDIT:
Launcher still complaining 'Error extracting archive'.  So if it's corrupt files, they have not been fixed.  Is it confirmed that the files are corrupt, or are you speculating?

EDIT:
.ZIP file for latest macOS release extracts OK and the extracted file runs OK, so seems like we're back to the launcher.  and nothing from them yet.

Edited by slamhauser
Link to post

There was outage on the openrct2.org infrastructure that resulted in corrupt ZIP files on 27 March.

I have just tried the launcher myself. Develop builds work, but release builds don't. (We always recommend develop anyway, but that's another thing.)

Not sure why it still serves the corrupt ZIP file for release, though, but it's still most likely to be a fault on the openrct2.org infrastructure, rather than in the launcher.

Link to post

The launcher, unfortunately, uses a hacky workaround to download builds from github. It's a somewhat different process than directly downloading the files from the openrct2.org website.
I've raised this issue months ago, but the latest launcher update was in 2017 and I don't expect this to be fixed anytime soon.

However, I'll look if I can change anything on my end in order to make the workaround function again.

Link to post

I'm 29, mostly tech savy, but I'm still struggling here.  Can someone almost remote desktop me and make it work?        I've already purchased it on Steam (RCT2 Thrill pack), and have an older Macbook Pro.  Thnx for any help or guidance!

Link to post

So with the development build OpenRCT2 (via the link in the Quickstart section) for macOS and the extracted files of the RCT2 demo (both the .exe and .zip) I do still get the following crash-information (see picture 1). Using the launcher yields exactly the same problem. Still does not work, though I might absolutely be missing a step here.

Schermafbeelding 2020-04-03 om 20.53.30.png

Edited by GvLiechtenstein
Link to post
8 hours ago, Gymnasiast said:

@BrianWhat error messages do you get? Did you download a release or a develop version? Do you use the Launcher?

I downloaded the stable version of open RCT2, and I purchased on steam RCT2 Thrill pack.  I think the problem I’m having is getting the.EXE file off of steam because I’m using a MacOS.  I know that when I launch OpenRCT2 it asks for the location of the RCT2 file, but I just can’t get that exe file.   If that makes sense.  

Link to post
  • 3 weeks later...
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...