Jump to content

g2.dat corruption

Recommended Posts

Okay, so I have an interesting problem.

I decided to update the game to the lastest network version this morning and when it tried to launch, it said "Could not load g2.dat" Weird. So I went to find the file and there it was. Unreadable. 0kb was the size of the file so I knew something was off. So I thought "maybe it's the build so I'll just reinstall the old build" so I did. No luck. So then I decided to reinstall the original game and replace the g2.dat with a fresh one. AGAIN, no luck. File was still corrupted even after being replaced. So I tried DELETING g2.dat then installing the game to INSURE it was being replaced. And it was replaced, but still got corrupted. HOW?

Any ideas on how to fix this? Perhaps there's a download somewhere where I can download a working g2.dat file? I was using a demo installer by the way, not the disc.

Link to comment


1 hour ago, SK_Productions said:

So then I decided to reinstall the original game and replace the g2.dat with a fresh one.

g2.dat is part of OpenRCT2, it has nothing to do with the original game. If your g2.dat has been corrupted somehow, reinstalling OpenRCT2 should fix it. If it doesn't, something odd is going on.

Link to comment

Okay, found something interesting. A friend of mine copied his g2.dat and gave it to me, so I tried to replace it with his. But, failure. I got this error below. So I tried to delete the current g2.dat and THEN replace it, but then it keeps coming back. This same file with the same error. WHAT THE HELL IS GOING ON HERE?! I've reinstalled Openrct2 5 times now and the original game 4 times. I've tried 3 different builds, one with network 2.20 which what was working before, and one from 2 hours ago and one from this morning.


Link to comment

The g2.dat file should be in        c: (or whatever your main hard drive letter is)..... at.... C:\Program Files\OpenRCT2\data. It should be around 106 kb large. There should also be a much larger G1.dat file in that same folder next to the g2.dat file that is about 16.5 MB large.

Openrct2, for me, on my windows vista laptop, installed itself in a weird way. It created the folder mentioned previously, but it also made a folder in "my name"\documents\openrct2. I used to run the openrct2.exe from this "my name"\documents directory, (i think)... But now the openrct2.exe i use is in "C:\Program Files\OpenRCT2\openrct2.exe".

Anyway you could have a virus or malware that is causing a problem. Maybe your administrative privileges are messed up, are you the administrator of the computer? Do you have "uac" user account control on? I would turn it off if i were you. I don't know what else to say, maybe some of these ideas might help... Make sure you are using the computer and installing stuff as you/ being the administrator. Turn uac off too if you have it on. Try looking for an exe file in "your name"\documents\openrct2.

Edited by joshmarsilio
Link to comment

Yes, I am the administrator. Had the pc since it was new. No I dont have a virus, and I know this because I have openrct2 installed on a usb stick. Pathetic, I know. 28gb storage pc. Anyways, I have never had an issue like this until now. My G1.dat is fine. Same size as you stated. I have no idea was uac is lol but probably not. I don't have much else to state.

I stuck the usb into another pc and tried replacing it but it kept coming back so its not a virus.

Link to comment
  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...