Jump to content

Scenery and rides not loading for custom scenario

Recommended Posts

I wanted to create a sandbox environment for adding scenery to custom rides, so I maxed out all of the limits on how many scenery and ride items can be included. The first time I used the scenario, most everything was working. I did notice that a few scenery items hadn't loaded--there were no previews in the selection window, and when I tried adding them to the map, there was either nothing there (for static items) or just a little flickering diamond (for animated ones). (See the gif.) There were previews missing for a few of the rides as well.

I saved the game, closed RTC, and came back to it the next day.

When I opened the park I'd started with this scenario, most of the scenery I'd put in place had disappeared, and when I try to create a new park from the scenario, that same scenery is invisible there as well. If I return to the main menu and then open it up again, sometimes a couple of items that had been invisible have come back, or vice versa.

I assume that this has to do with trying to cram so many item types into a single scenario, but if that's the case, then the caps need to be adjusted.

The gif shows what I'm seeing (in the red helix, there's supposed to be a volcano--a static object, so it's just invisible--with 16 little fire objects inside--which are animated, hence the wobbling squares), and the troublesome scenario is attached.

I'm running the latest OpenRCT2 with the RollerCoaster Tycoon 2 Triple Thrill Pack from GOG on Windows 10.



Edited by Soni
Link to comment

Jensj, this happened for me immediately after I opened the game, before I'd loaded anything else. I did also try opening and closing the game a few times, and while the number of glitched objects would change, there were always a few that wouldn't display.

Link to comment

I used to get glitchy objects if i told the launcher to download "stable" instead of "develop" mode or maybe it was the other way around, i don't remember exactly which one was which, all i remember is that one was glitchy and one wasn't. Anyway, maybe if you go into options from the launcher start window, and next to "Branch:" select "develop" instead of "release" or vise versa, then you might stop having glitched objects.... ?.?> Though your problem may be being caused by something else that i'm not aware of.

Edited by joshmarsilio
Link to comment

@joshmarsilio, it was set to "Develop" by default, and I tried changing it to "Release." That gave me way more glitchy objects!


I'd be happy to post in Github, though I'm not really familiar with issue tracking there--is there any particular protocol for how to post, or should I basically just copy-paste the description (or summarize the description and discussion?) from here?

Link to comment

Just go to https://github.com/OpenRCT2/OpenRCT2/issues or click on "issue tracker" in "problems bugs and feedback". You then have to sign up with github, but this is not too hard to do. You also may need to use firefox or ie browser for github, if your chrome or browser is not up to date (i use firefox for "github"). Then after you are signed up, and signed in at github, post your issue by pressing the green "new issue" button. Follow the instructions such as giving them the version of openrct2 you are using, and your computer operating system etc. You could then just copy and paste your issue there if you want to, and submit it. That's it.

I'm surprised you got even more glitches by changing to "release" but there is obviously some kind of problem, so telling them at github would be best.

Edited by joshmarsilio
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...