Jump to content

Recommended Posts

While getting the files together I noticed the older file with no error was created with "export plugin objects" turned off.  The files with the error are ones with it turned on.

I created the "packed" files with vanilla RCT2 and OpenRCT2 and I get the same result with both.  So this is not a OpenRCT2 bug with creating the files.

Any idea what the issue may be?




Edited by Millionaire2K
delete files.
Link to comment

Sounds like there's a conflict between two files then. I've had something similar happen to me a few months ago, where there were two objects with the exact same name being loaded.

Got to %Appdata%\..\Local\VirtualStore\Program Files (x86)\Infogrames\RollerCoaster Tycoon 2\ObjData

Remove the (x86) if you are on a 32-bit machine. Look for a file with the name AE-DMGBY.DAT, and check if you've already got this in the installation folder of RCT2. I suspect that the same file is there as well, which conflicts with this virtual folder. If it exists in both folders, you can safely remove one of them.

Link to comment

I only have the file once in the ObjData folders.  However it is also in the Data folder for some reason. 

Also is it safe to cut all the files from the VirtualStore and merge them with the main game dir?




A tool of some kind to "cleanup" the folders and save files would be great.

Edited by Millionaire2K
Link to comment

This is not a bug in OpenRCT2 (well, it sort of is since OpenRCT2 is supposed to fix this problem, but that's not the root cause of it). It does not mean your park file is corrupt. This error occurs because the AE tracked rides were created with Buggy's ridemaker, and Buggy's ridemaker has a bug that causes it to write 0xFF in three locations that are supposed to be zero. When the object is exported, those bytes are set to zero, but the checksum is not recalculated so you end up with a checksum mismatch when you load the park.

The error doesn't occur if you don't export the park because it is the object included with the SV6 that is broken, not the one in your ObjData folder.

I tried to fix this problem by having the game recalculate checksums when exporting objects, and padding the file with extra bytes that force the checksum of the fixed file to match the original. Unfortunately this code doesn't seem to be working properly in all cases - I will need to have another look at it at some point.

If you have the DAT file in your ObjData folder, you don't need to worry - the game will simply load that one instead - but if you post the park online it's a good idea to also post or link the custom ride so that people who don't have it can download it. If you don't have the DAT file in your ObjData folder and can't open the park because of it, you can select "Allow loading with incorrect checksums" to ignore the checksum mismatch and force the park to load.

Edited by X7123M3-256
  • Like 2
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...