Jump to content

Object Load file failed. Potentially currupt file.

Recommended Posts

Hey guys, I'm on windows 10, been playing OpenRCT2 for about 2 and a half weeks, went to go play and every time i attempt a launch threw the launcher window. or via the normal openrct2.exe i get these error codes, i've attempted updating and re-downloading the launcher more then once, still getting the same problem.

Image of the command prompt. Copy of RCT2TTP is from disk. Any help would be fantastic guys!


Update: For Anyone Else who might have this problem try moving your custom content to another folder or deleting it and see if that works.

Edited by Manoman
Link to comment

There's a corrupted file, not sure if it's causing the crash or something else, but it's worth fixing anyways.

Do you have any custom scenery objects in the game's data folder? Have you tried replacing the object files on your computer with the ones on the disc?

Link to comment

I do have some custom scenery and rides, and i haven't as my CD player isn't plugged into at the moment. not sure what would have caused the corruption, as i played the game just before, then had to restart my computer due to an update i think? after i tried playing the game again and got this. also i can't find the file that is corrupted. as the name they showed isn't in the data or objdata folder.


Update: I'll Try temporary  moving only the custom content from my games obj data and see if that fixes it, if that isn't it i'll try to find my RCT2 disc and reinstall the game. I've had the game installed on this computer for about 5 years now so might not be easy to find haha


SuperOtherUpdate: Seemed to fix it, now i just need to find out what file is the one that is corrupted.

Edited by Manoman
Link to comment

VERBOSE: loading object, D:\Old_Drive\Games\RCT\RollerCoaster Tycoon 2 Triple Thrill Pack\ObjData\GWGRPBB.DAT
ERROR[src\util\sawyercoding.c:107 (sawyercoding_read_chunk)]: Unable to read chunk data!
ERROR[src\object.c:102 (object_load_file)]: Object Load failed due to checksum failure: calculated checksum -2137901753,
 object says 2094446126.
ERROR[src\object_list.c:756 (install_object_entry)]: Object Load File failed. Potentially corrupt file: *╛¬7═¼⌐â
VERBOSE: loading object, D:\Old_Drive\Games\RCT\RollerCoaster Tycoon 2 Triple Thrill Pack\ObjData\GWGRPPST.DAT

This is the info that I seemed to have got, but i'm not sure if this even helps. I've tried removing both the GWGRPPST and GWGRPBB but they also seem to be part of the main game as far as i can tell?? The game runs now, and i'll be uploading the GWGRPBB.DAT and its brothers which seems to have been the problem? most if not all of my custom content is from my friends server, so maybe they failed to download correctly?


Edited by Manoman
Link to comment

Delete the corrupted files and make sure you get a fresh copy of the files in your data folder. Redownload the corrupted files if you got them from the internet. If they are from the original game, copy them again from the cd. If the files were extracted from a save file, redownload the save file and extract them again.

Link to comment

Hey everyone after re downloading the files via New element it seems placing any one of the three files i've shown to you causes the same ( ERROR[src\util\sawyercoding.c:107 (sawyercoding_read_chunk)]: Unable to read chunk data!  ) Any Ideas on what could be causing this?


Edit: Here are the new not corrupt fresh GWG------- Files just encase you guys would like to compare them in some way.


Edited by Manoman
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...