Jump to content

Invisible Ride Icons/Ride Trains


Recommended Posts

Hey there.

 

Sorry if this issue is already known/document somewhere..

 

After the update to 4.0, some coaster trains do not show up at all in game. The same goes for the ride menu, where I can hover over and select a ride type, but it has no icon at all. When I try to place these rides, they show up as invisible, or in the case of coasters, I can build the coaster, but the trains are invisible. I can use hacks/cheats to use a different vehicle type which shows up fine.

 

This was not happening to my knowledge at all before the 4.0 update, have been on this setup working fine for some time.

 

Any help would be greatly appreciated!

OpenRCT2, v0.4.0 (c6302a1)

MacOS 10.15.7 Catalina, running on a hackintosh (i7-7700k, RX580 8GB, ASRock MB)

Untitled.png

Untitled 2.png

Untitled 3.png

Link to comment
  • 2 weeks later...
On 26/05/2022 at 11:53, jensj12 said:

IIRC this is caused by a mixed install (files from different versions of OpenRCT2). Uninstall OpenRCT2 and install it again and it should be good.

Thanks mate.

I tried to uninstall/reinstall but no luck.

Not sure how to get rid of all my files on Mac OS.. Tried deleting everything I could find including the application, and reinstalling from fresh download.

Link to comment

This is caused by missing files in the ObjData folder of your RCT2 install. As OpenRCT2 has its own metadata, the vehicles will show up in menus and _behave_ correctly, but no images will be loaded.

What version of RCT2 do you have? E.g. CD, GOG, Steam.

  • Like 1
Link to comment
  • 2 weeks later...
On 08/06/2022 at 16:18, Gymnasiast said:

This is caused by missing files in the ObjData folder of your RCT2 install. As OpenRCT2 has its own metadata, the vehicles will show up in menus and _behave_ correctly, but no images will be loaded.

What version of RCT2 do you have? E.g. CD, GOG, Steam.

Thanks Gymnasiast and jensj12.

 

I have RCT2 from Steam. I am running on Mac OS, so I have my whole RCT2 install uploaded to the cloud to put on any new machines to use OpenRCT2..

Re downloading and replacing the ObjData folder now to see if it makes a difference.

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...