Jump to content

Enabling OpenGL and changing window scale factor to 1.25 leads to permanent black screen

Recommended Posts

I recently ran into a problem where I (today) installed OpenRCT2 on a new laptop. While I was beginning a Crazy Castle scenario, I wanted to change the window scale factor because the icons were a bit small. It worked, but the icons were also a bit blurry, so I tried to switch the engine to OpenGL. The game froze and went black. I tried to, but couldn't, close the software with the title bar, so I used the task manager. I opened it with verbose, which looped this error after a while:

ERROR[D:\a\OpenRCT2\OpenRCT2\src\openrct2-ui\drawing\engines\opengl\OpenGLAPI.h:121 (CheckGLError)]: OpenGL Error 0x050

I close it, and installed the launcher. It worked at first, but then I opened the original application with the bug and it seemed to sync.

I'm glad I could report this bug, but for now, what can I run to fix the problem?


Link to comment

Two other things. Behind the black screen, the game runs as usual. GUIs work and open like the options panel (though I can't see it, so it's a bit difficult to fix like that), music plays, the roller coasters on the title screen make noise, etc.

The other thing is that I deleted both the original application and installer using the uninstaller in the program files, and now it's working. However, it would be nice to have a solution that wouldn't require deleting all of the data in a game, especially if I had lots of prior data on the game from before.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...