Jump to content

A pretty odd error.

Recommended Posts

I've been working on my Cedar Creek Park forever (Link to the RCTgo thread about it here:) http://forums.rctgo.com/thread-21546.html

I came upon a bug, which for some reason affected both RCT2 and OpenRCT2. Every time I load Cedar Creek, it works great, but, if I zoom out or even go to a certain spot in the park, the game crashes immediately. Every time, every time. WHen it does, it pops up an error note.


I'll read out exactly what the note says:


Assertion Failed


Program: C:/Program Files/OpenRCT2/openrct2.dll

File: src/paint/sprite/sprite.c

Line: 80


Expression: False


And then it says something about reading something to get what's wrong.


It also has three buttons to click, Abort, Ignore, and Retry. Only abort works.



If you can help me with fixing whatever this bug is, PLEASE DO!!!


I've already tried three times to create a good park, and every time, something failed. 

Whether it be a computer death, or the game breaks, I've tried and tried. 





Link to comment

Alright, I managed to remove the broken file from the game entirely, and it DID help, although, the game would still crash on that particular save. 


I guess it's good that I save so often. I used the save before the one that was broken, and it seems the bug has been fixed.

HOORAY!!!!! Cedar Creek's still up!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...