Jump to content
OpenRCT2
Sign in to follow this  
Ling

Server not working - already tried all of the steps found in this forum

Recommended Posts

Trying to get a small server running for some local friends (max ~5 players at any one time), sadly do not have any way to get my dedicated server PC attached to our router at the new place, so I cannot run it headless although I would eventually like to. In the meantime, I just want to get something working so I can share the steps with everyone, get them connected, and see if they like it. I have a dynamic DNS set up through no-ip to make things easier, although I have tried connecting with and without to similar results. NAT is enabled.

I tracked down my public IP address, and am port forwarding 11753 to my desktop, which has a static IP (or my router is smart enough to follow the MAC address, it's not entirely clear which but the IP address hasn't changed in the course of my troubleshooting). I am testing it by tethering my MacBook Pro to my phone to simulate an outside network. When I put in either "<public IP>:11753" or <name>.ddns.net:11753" it sits on Authenticating for a while then says No Data. I am running it with a password, and currently a max of 3 players. Canyouseeme.org can see the IP and the port just fine. I have also permitted the port access in both Inbound Rules and Outbound Rules in Windows Defender, although that does not seem to have changed anything.

Advertising vs. not advertising doesn't seem to make a difference. I cannot see my server name on the client either way, and cannot directly connect either way. Looking for any other things to try.

EDIT: Both clients are running the Develop branch, both use launchers and so are currently on the most recent versions of the game.

Edited by Ling

Share this post


Link to post

Minor update: A friend with a Windows 10 PC was able to connect successfully, but is getting disconnected every few seconds without any further info. Our public IP hasn't changed, and doesn't seem to be dynamic. My MacBook Pro, still also running the latest developer branch and also running network 0.2.1-2, cannot see the server on the list at all. Any attempt at a direct connection, either internally on the same WiFi (to the internal IP) or tethered to my phone and connecting to <our public IP>:11753 fails completely. I do not currently have access to any other machines to test with.

Share this post


Link to post

I have never been able to start a server myself and i have never really tried to. But i did research what i would have to do to start a server:

Are you sure you opened a port or ports through your internet service provider? That's one of the things i think you have to do.

Edited by joshmarsilio

Share this post


Link to post

Yes, that is one of the first things you have to do, and I have done it before for in-house Filezilla and Minecraft servers. Canyouseeme.org was able to successfully ping the port and my friend was able to see it on the list, although he wasn't able to maintain the connection to it (I am starting to suspect he may have been having internet problems at the particular moment we tried this, which could be compounding the problems and make me suspect a problem with the network when in fact it's seemingly more likely a problem with the particular version of the server running on my PC, i.e. headless vs. client). I am unable to connect to it from my MacBook Pro using the same network version from outside the network, but can connect from the LAN. Was able to check my girlfriend's PC and it can successfully connect from inside the LAN too. One thing I have noticed is that it seems extremely sensitive to order of operations. If I start a server using the OpenRCT2 client (e.g. to set permission) and then switch to a headless server running on the same PC, the headless server constantly errors out that it was incapable of advertising, and nothing can connect to it (including a localhost connection from the same PC). However, if I start the headless server first, then I can connect to it on the same PC as well as from other PCs on the network. The problem there is it's not currently possible to give anyone permissions - the commands don't seem to exist for headless servers, and using a whitelist.json that has my client player name doesn't work. Whichever form of server I create first (headless batch file or OpenRCT2 client), only that type of server works until the computer is restarted. Very strange. Somehow one program takes ownership of the port and doesn't give up control until the computer is restarted. I still have not been able to get anyone to successfully connect from outside of the network for longer than a few seconds, but hope to get more people onboard to try different things tonight.

Edited by Ling

Share this post


Link to post

Open your task manager and look under the background processes section. This was how i got mine to work repeatedly after my ports would be open.

Untitled.png

  • Funny 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...