Jump to content

Creating a Custom Title Sequence

Recommended Posts

I am having trouble making my own custom title sequence in Open RCT2. I am not sure if it is a bug in the game or if it is my fault. On the main menu I go to the top right of the screen to the options menu. I go to the miscellaneous tab (the one with the wrench) and open up the title sequence interface. I click create and enter "Custom Title Sequence" as the name, but the game just says, "Failed to load. . . file contains invalid data!" What can I do to get past this? Is there something I am missing?

Link to comment
  • 6 months later...

The error pops up when I'm in the dialog box telling me to type in the name of my custom title sequence. I type "Custom Title Sequence" and press enter, and it says, "Failed to load. . . file contains invalid data!" The game will also not load the original RCT1 title sequence when I click Roller Coaster Tycoon 1. Instead it loads the Roller Coaster Tycoon 2 title sequence.

Link to comment

Can you try running openrct2.com from the .bin folder, and going through the same steps. Post any warnings or errors you see in the console here.

The latter issue is probably because you don't have the RCT1 scenarios. A warning for this should also be printed to the console.

  • Like 2
Link to comment
  • 1 month later...

I also seem to be having the same problem, regardless of where I run the program from. I'm on Windows 10. I get the same error when I try to create a new sequence. The name "Test" here stays on the opening sequence menu after I try to make it, but I cannot edit any of the info for it. Further, if I try to duplicate any of the existing sequences, it allows me to rename the copied sequence, but the copy doesn't show up on the Title Sequence dropdown menu. Hope I'm not necro-ing a dead thread here, but it looks like there was no solution yet.

RCT Opening Seq1.PNG

RCT Opening Seq2.PNG

RCT Opening Seq3.PNG

Edited by Avalanche
Link to comment
  • 2 weeks later...

Hey, all. Don't know if you solved this yet.  There's a fix on the way.  In the meantime, here's how I got past it:

Find the OpenRCT2 folder in your documents.  It should contain folders like bin, landscape, save, scenario, track.

Create a new folder called "Title Sequences" (without the quotes).  

Now when you create a new title sequence using the steps above, it will create in that folder and work properly!

  • Like 2
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...