Jump to content

Loading Old Saves


Recommended Posts

Hi, I am new here and I just have to say I am 100% impressed with this.  It is amazing that I can finally play RTC2 on my mac.

 

I was just wondering if there was anyway to load old saved data to make it usable again.  I directed the load to my big folder I had saved from RTC2 on my old computer and I saw that when I clicked Load Game on the main menu screen, when I went to open one it said it was unable to load...is there anyway to load old saves or not?  If not, I guess it is time to spend way more hours than necessary building new ones!

 

Thanks again for making this!

Link to comment

You might be having an issue of incorrect checksums in the save file. Just to make sure, is the option "Allow loading files with incorrect checksums" enabled? It's in the Miscellaneous options tab.

You should probably upload the save file in any case. .sv6 is still the file format for OpenRCT2 save files, and you should be having no issues migrating them over from RCT2. Also, could you be exactly specific as to what the error says? Thank you.

Welcome to the forums!

Edited by ziscor
Link to comment

What is the specific error you get? While an incorrect checksum is a possiblity, I think it's more likely that you are missing one or more of the objects required to load the park. It is possible that the park has a hack that doesn't work in OpenRCT2 (in which case, it's a bug in OpenRCT2 that would need to be fixed), or it could be that the save is actually corrupt.

Link to comment
14 hours ago, ziscor said:

You might be having an issue of incorrect checksums in the save file. Just to make sure, is the option "Allow loading files with incorrect checksums" enabled? It's in the Miscellaneous options tab.

You should probably upload the save file in any case. .sv6 is still the file format for OpenRCT2 save files, and you should be having no issues migrating them over from RCT2. Also, could you be exactly specific as to what the error says? Thank you.

Welcome to the forums!

The error states: "unable to load file..." even after I checked the "allow loading files with incorrect checksums.  The files are in the right format they just dont seem to be working.  I am using the MAC version if that helps with anything

Edited by rangerdanger0
Link to comment

Is that all it says? Normally, if there's an invalid checksum it prints an error to the terminal saying so ... same if there's a missing DAT. Maybe try running with --verbose (which enables extra logging) - else try uploading the save somewhere and see if others can open it.

Link to comment
57 minutes ago, X7123M3-256 said:

Is that all it says? Normally, if there's an invalid checksum it prints an error to the terminal saying so ... same if there's a missing DAT. Maybe try running with --verbose (which enables extra logging) - else try uploading the save somewhere and see if others can open it.

I figured out the problem, it was going to the wrong folder so now If I want to load a game, then I gotta kinda back track and find the right folder, not to hard so its not a big deal

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...