Jump to content

MP crashes when trying to play with a friend (on RCT2, nothing wrong!)

Recommended Posts

So me and my friend are trying to play together on RCT2, created a park and threw the server on and it worked at first, we joined eachother, we started to play and this popped up;


We decided to both install a newer version and when we try now, as soon as my friend is trying to join me (custom map, 203x203), his ping shows as 375 and instantly disconnects. When asking him what happened, he said he just got disconnected while downloading the map. Is there something we can do to fix this? We haven't tried the very latest build yet but we did update ours to a newer one to see if it'd make any difference.

Link to comment

A likely reason is the server has some objects that are not available to client. You can perhaps overcome this by re-connecting for the second time, if that was the case, then the cache should have been rebuilt by then and you should be able to connect easily. Alternatively, you can send you friend a map you intend to host (make sure "export plug-in objects" option is on) for him at least once before you connect.

I don't think there's anything else you could do on your end to alleviate this problem.

See https://github.com/OpenRCT2/OpenRCT2/issues/3057

Edited by janisozaur
  • Like 1
Link to comment

Both our internet connection's stable enough Imlegos, we play games quite often together and have no issues whatsoever. It only happens to this game, RCT2 MP when we get this issue. I think it's just because of the custom map that the issue occurs because when we choose an empty scenario that's from the game itself, it doesn't seem to give any issues.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...