Jump to content

Works great on Switch, but if I close the game, and open it, all my progress disappears

Recommended Posts

Posted (edited)

[Nintendo Switch] Roller Coaster Tycoon 2 / Tycoon 2 (OpenRCT2) [ENG] [NSP] :: RuTracker.org

I used this Eng/Rus torrent with 1.06 version for homebrewed Switch. (maybe you can censort the link if it breaks the forum's rules? :/)

It has 2 folders that I was supposed to move to the root directory of my SD card (for Switch), and then install the small 300 kb NSP file, which of course I did. At first sight everything runs very well. There is Russian language in the game, which I instantly changed to English -UK- in the Game options. I decided to have a bit of fun in the first level to see if everything works. After a bit of playing, I made a save-file of my game + made changes in the Game settings (Currency, Night&Day). The game was responsive. I could later return to the game's Main Menu, and load my Save from the 1st stage from there. Again, everything worked.

Then I quitted the game by closing this application in my Switch panel. I opened the game once again (Once again it was opening for 1 minute with black screen btw, I had thought it was supposed to be this long only when launching for the 1st time, not each time?), aaaand..... it's back to being in Russian language...  and all my changes in the game settings are also gone, and my Save from the first mission disappeared.

Whenever I close the game, my progress & my changed settings don't show up anymore when opening the game next time on my Switch.

I have the feeling that the solution must involve doing something simple. For now, the game prevents me from storing my progress for the next session. I would be extremely thankful for help, since it's a game that my wife has always been dreaming of playing on our Switch.

Edited by Zalo248
Link to comment
  • Zalo248 changed the title to Works great on Switch, but if I close the game, and open it, all my progress disappears

From your description it seems that the Switch itself erases all files when closing the app (including settings and all index files which take time to rebuild). You might get more help in communities for the Switch instead of OpenRCT2. I assume similar issues arise with other games that are manually ported to the switch.

Link to comment
Posted (edited)

Okay, it worked now.

I opened the SD card on my PC. "config.ini" file in the Home folder, which had that russian language fixed to it, and I found out that I was unable to make any changes to it from my PC (even when opening Notepad as Admin), so I just moved that config.ini to my D drive, edited it (English language, Day&Night cycle, Currency, Show Intro, etc), and since I couldn't overwrite it, I saved it as a completely new config.ini to in that Home folder on my SD card. Then, upon opening the OpenRCT2 on Switch, the game not only I had English language + Night & Day cycle, but somehow I could still make some changes to the settings while playing, and those changes would still carry on when turning the game off and on. Save files carry on to the next session as well btw!

So the russian torrent uploader must have simply made that config file preventing people from making any changes to the game at all. OpenRct2 is surely not at fault here. Game runs really well now.

EDIT: Is there any way to replace the 2 analogs with each other, so that it is the right one to act as the Cursor and the left one would move camera? 

Edited by Zalo248
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...