Jump to content

Updating from to 0.4.1 causes missing object rct1.ride.steel_rc_trains

Recommended Posts

Hi.  Having a weird issue and after googling for a while and looking through the issue tracker I couldn't find an answer.

Issue:  Updating the version 0.4.1 causes a missing object message box showing rct1.ride.steel_rc_trains.

How I found out:

I'm running Linux Mint 20.3.  I had originally installed OpenRCT2 through the software manager.  I noticed there was an update, and that I would need to add the PPA and install that way (updated version was not in software manager).  So.  I uninstalled the old verson, and installed the PPA for the nightly.  After the install, and selecting the path's to my game files I tried to start Forest Frontiers.  I got the following error: 


What I have tried:

I tried extracting the game files again, removing config files etc. and still couldn't start that scenario.  I tried many other RCT1 and RCT2 scenarios but didn't have any other issues.  I also tried uninstalling, removing the nightly PPA and using the Master PPA and still had the same issue.

Removing everything and installing the older version through the software manager works fine though.

This isn't a massive issue for me, as I am happy with  But wanted to report it anyway just in case.

Edited by Wisky
Link to comment

This is usually caused by a mixed install. Uninstall OpenRCT2 (don't delete your saves/tracks/etc!) and install it again. In particular, make sure the official OpenRCT2 object files for the original objects are from the same version as the build you are using, these can be found in [installation folder]/bin/data/object/.

  • Like 1
  • Informative 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...