Jump to content

Can't get OpenRCT2 to run on M1 Macbook

Recommended Posts

I followed the instructions to download RCT2 on Steam on Mac with the console, and then I tried both the stable release and the OpenRCT2 launcher but neither one accepted the RCT2 files I downloaded from Steam.

With the stable release, I got the same error screen every single time, no matter what I tried.  I also tried older versions of the stable release but it gave me a longer version of the exact same error.  I attached both of these error messages.

The launcher gave me the much longer error message that I attached an image of.

I also bought the GOG version but I cannot find a compiled version of the software required to get the RCT2 installation on Mac so I didn't think that was the better option.

What should I do now?

Screen Shot 2022-08-29 at 9.35.43 AM.png

Screen Shot 2022-08-29 at 9.37.02 AM.png

Screen Shot 2022-08-29 at 9.33.58 AM.png

Link to comment
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...