Jump to content

Error with connecting to advertise server (SSL CA cert )

Recommended Posts

I'm messing with trying to create a linux/php based website management system where a user can upload a scenario file then reboot my server with the new scenario file. I was able to successfully start the server with a php script that basically opens openrct2.exe on my remote linux server with wine and points to the scenario file, and was able to connect to the rct server from my home pc. However, when I kill the server using killall openrct2.exe and attempt to restart it with a different scenario, I get errors with the advertise server that appear to prevent me from connecting to it. When I connect from my pc, it gets to the authentication stage then is unable to complete the connection.

Ready for clients...
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub
ERROR[src\network\http.cpp:135 (http_request_json)]: HTTP request failed: Problem with the SSL CA cert (path? access rights?).
WARNING[src\network\network.cpp:882 (Network::AdvertiseRegister::<lambda_daae3c5cee0e3be7d009c502fe4f504e>::operator ())]: Unable to connect to master server
^Cfixme:console:CONSOLE_DefaultHandler Terminating process 36 on event 0

Does anyone have any insight on how I can fix this? The first startup after a while works fine, but subsequent startups get this HTTP request failure.Maybe there's a more graceful way of killing the server than killall openrct.exe that wont create this issue with the ssl ca certificaiton?

Link to comment

windows builds require a certificate bundle, which we ship in windows artifacts.

There is an error right there in the logs:

ERROR[src\network\http.cpp:135 (http_request_json)]: HTTP request failed: Problem with the SSL CA cert (path? access rights?).

When you restart, you probably have wrong CWD set.


I have to ask though: why would you use wine and windows build to host this server? That's super weird to me.

Edited by janisozaur
Link to comment

I was under the impression that the only way to use rct2 and openrct2 on linux was through wine. I have had the linux server for a while now and I wanted to mess around with installing openrct2 on it. I'm not that well versed in any of this so I may be doing something completely wrong. I've done a sort of a fix that has worked after some testing that involves me switching between the following two scripts:

cd /var/www/ && HOME=/var/www/ wine /var/www/rct/openrct2.exe --headless --port 11753 /var/www/rct/frontiers2.sv6 > /dev/null &

cd /var/www/ && wine /var/www/rct/openrct2.exe --headless --port 11753 /var/www/rct/frontiers2.sv6 > /dev/null &

By switching between setting the wine HOME and not setting it when I run the game I am able to restart it and connect to it multiple times in a row (when I start the server I use the script that isn't the one I used to start it the previous time). I am not sure why this is though because I am not great with this stuff, so if you have any insight as to why this may be that'd be awesome. If not then I guess we can consider this resolved for now.

Link to comment

Not sure how you're looking, but this is quite Linux looking to me: https://github.com/OpenRCT2/OpenRCT2/releases


We've had that for couple of months now.


See https://github.com/OpenRCT2/OpenRCT2/wiki/Building-OpenRCT2-on-Linux

We have a few packages already, not yet release-quality, but they may be available for your system. What distro you use?

Edited by janisozaur
Link to comment

Got it, will mess around with it tomorrow.

Also, I discovered the original issue I was having was that I kept my game open between server restarts. It turns out I had to restart my game each time I restarted the server or it wouldn't connect to the server.

I was able to put together a website that lets my friends upload and play scenarios on my server and it works now that I know I just need to restart my game.


Edited by Tioga060
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...