Jump to content

Game Crashes When Trying to Join Certain Multiplayer Server

Recommended Posts

My girlfriend and I have been playing a variety of scenarios together on my multiplayer server for a couple weeks. When she tried to log on recently, however, (only a few hours after everything was working fine) the game would crash after just a click on the server. It will crash immediately every time. No error message on either end. She can connect to any other server. Frustratingly, it really seems as though nothing changed on either end to make this happen.


She’s uninstalled and reinstalled OpenRCT2, restarted her computer, I’ve restarted mine, tried a variety of multiplayer settings, verified strong internet connection on both ends... We’re at a total loss. It just suddenly stopped working; not even so much as a restart in between. As far as we know, all she did was close her laptop for an hour or two before trying to log back on.

She’s on a recent MacBook, fully updated. Windows for me.

There’s no obvious error code; if there’s a way to get more details about what’s going on in the background, maybe someone could let me know. Any suggestions?


Link to comment

Figured it out! Didn't suspect this at all, but the problem was her internet after all, though not the strength of the connection. By switching to a different network, everything worked fine again.


Now the problem is figuring out what exactly this network has against OpenRCT2... Doesn't seem to be the firewall.

Edited by Torsman7
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...