Jump to content
OpenRCT2
Sign in to follow this  
RollerBoaster

Paths missing - possible bug/issue

Recommended Posts

I've used the tile inspector to look into this a bit more and it seems all three paths may be missing that drop off the list in the scenario editor- two have defaulted to the last path that does show in the scenario editor and I think the third has defaulted to some random other path, difficult to figure out- I'm still looking into it but I do think that three paths are missing which work fine in vanilla (not sure if you'll be able to view the park in vanilla)

 

What info would you need from me in order to establish if it's a bug or a path object limit (it could be the latter and not fixable but vanilla rct doesn't seem to have the same problem/limit- it may be unique to orct or something orct dislikes about these path files), will try to get some vanilla screenshots to show the difference.

 

Relates to path issue mentioned here: https://forums.openrct2.org/topic/4638-missing-custom-scenery-items-part-solved/

 

Game save file below image:

 

pathmaster.SV6

bottom of editor window 1.PNG

Edited by RollerBoaster
Link to related post, updated image

Share this post


Link to post

In vanilla (note that I've created a new problem in that I now have the desert path listed twice in the editor, possibly as I tried renaming the files in case orct disliked the filenames after discovering this problem (whilst keeping the originals), may have lost track of the 2 new files!, hasn't changed how vanilla/orct handle the path options though, and the savegame has the original files before I duplicated and renamed them:

 

in vanilla.PNG

in vanilla2.PNG

Edited by RollerBoaster

Share this post


Link to post

In ORCT - nb only ORCT has the paths listed as new path- these are named in vanilla- they may include the 'missing' rozy path (as orct's tile inspector shows it as 'new path')- but the mising rct fan paths aren't here  ------------ Update: desert path 'patrctfa' name here is the duplicate's name, the correct problem filename is patrctfan#dp as per my most recent update post

 

 

orct bottom list.PNG

only orct has these.PNG

ti newpath.PNG

Edited by RollerBoaster

Share this post


Link to post

I've found the new problem's cause and fixed that- deleted the leftover renamed duplicate I made (PATRCTFA) as it hadn't fixed the problem but I missed deleting it

 

now it's gone I don't get the duplicate in vanilla's scenario editor (the problem is otherwise unchanged)

 

My three questions would be:

 

-why does orct lose the names of some paths and just label them 'new path' where vanilla shows their names (such as 'rozy path' if it's used the same path in orct), likewise vanilla seems to show the full names whilst orct shortens them (.....) in the list ?

 

-why can vanilla handle the sand  and  stone path but not orct ?

 

- does orct lose some path options and have a lower cap for number of path options than vanilla- or is there some other cause of it 'losing' some paths?

 

Also if anyone can clarify which dat files the test savegame 'pathmaster'  is referencing for the path choices that could be helpful

 

 

Thanks, I know solving these things can be a pain (and annoying if there's something really obvious with hindsight) but this is bugging me a lot as it makes me wonder if any other dats are affected and could cause any issues- I've noticed a few naming difference quirks with scenery items too, ideally I mostly like to design things that work the same in vanilla and ORCT when making landscapes/ scenarios.

rogue removed.PNG

Share this post


Link to post

Object selection cheat tool shows the two rct fan paths missing aren't selected- it has a path count that excludes them and they're not on the list of selected paths, so weirdly they're being ignored and not selected by orct when vanilla doesn't ignore them. So orct is duplicating the desert path twice in the path selection tool in-game in the two slots of the path orct is missing.

 

The 'new path' is there (the one I think is 'rozy path' but with its name not showing in orct)- I'll attach that file here as it's an example of one where vanilla shows a name for the path but orct doesn't and just calls it 'new path'.

 

I'll also attach the two files that MAY be the missing paths- I can only guess at this as vanilla doesn't give me the filenames (I'm not sure if you might be able to dig these- or the actual filenames if they're not these two- out of the savefile)

 

Finally the one that's getting duplicated in their place patrctfan#dp

 

 

PATH LIT.DAT patrctfan#snd.DAT patrctfan#st.DAT patrctfan#dp.DAT

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...