Jump to content

Broken sound / OpenRCT2 crashes when starting with title music enabled (i.e., by default)


Recommended Posts

Hi.

I have problems with the sound in OpenRCT2 v0.4.0 under my GNU/Linux system.

At first, I was unable to start OpenRCT2 at all. It immediately segfaulted. When I tried to debug it with gdb, I noticed that there was something going on with audio. If it's of any help, here's a backtrace:

#0  0x01515a42 in Mixer_Channel_SetGroup ()
#1  0x014ff86d in audio_start_title_music ()
#2  0x01487622 in title_update ()
#3  0x014bb515 in rct2_update ()
#4  0x014d450a in openrct2_launch ()
#5  0x01429276 in main ()

If you insist, I can try a later run on a debug build.

Anyways, after I found this I went to the config.ini and tried to tweak with some of the options. Finally I found the solution: Changing title_music to 0 made OpenRCT2 start and I could play it. But there's no sound at all, however and I have no idea to make it work.

But there's still a segfault when starting with title_music unequal to 0, so that's probably not my fault. ;-)

I noticed this line in the config file.

audio_device = ""

Empty string? Maybe that's why it doesn't work? What is audio_device supposed to contain? Also, in the audio options menu in the game, the topmost drop-down menu is empty. When I click on it, I only can select “none”. :-(

Has someone experienced a similar problem? Is this problem already known that OpenRCT2 crashes with title music being set?

Link to post

Sound is still broken for me and OpenRCT2 still does not recognize new devices, so I am playing a silent game. I am now using the development version but this didn't help.

 

Does really nobody have a clue on why my sound might be broken?

Link to post
4 hours ago, Wuzzy said:

Sound is still broken for me and OpenRCT2 still does not recognize new devices, so I am playing a silent game. I am now using the development version but this didn't help.

 

Does really nobody have a clue on why my sound might be broken?

 

No idea, but have you posted this on GitHub?  There are many more devs there...

Link to post
  • 8 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...