Jump to content

Unable to read map from server: Unknown exception

Recommended Posts

I updated the server openrct2 (ubuntu linux) version, and now I can't load maps from the server. Other clients do not have this issue. I have tried:


installing the .deb to the server directly

downgrading and reinstalling the server software

trying varying maps over different versions of the game

trying 8-10 different recent build versions


i have 2 other friends who are also playing on the server, and they're able to connect and download maps.


potentially helpful information:

client details


OpenRCT2, v0.4.6-47-g4147e9a (4147e9a on develop) provided by GitHub
Windows (x86-64)
Network version: 0.4.6-5
Plugin API version: 80
Current park file version: 31
Minimum park file version: 30
With breakpad support enabled


server details:


OpenRCT2, v0.4.6 (, DEBUG)
Linux (x86-64)
Network version: 0.4.6-5
Plugin API version: 81
Current park file version: 32
Minimum park file version: 32
Breakpad support disabled

The server is running on an AWS VPS, and has worked for about a week prior to the issue w/ the upgrade.


It acts as though it's going to load, downloads about 1/3 of the total kb size of the map from the server, and then throws the above-mentioned error while running verbose.


Any help would be greatly appreciated. Thank you!

Edited by unstubbabletoe
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...