Jump to content
OpenRCT2
nibs99

Starting a Server Fix

Recommended Posts

i think i figured out the server thing more so than before.

my first thing to try for you is to open your windows firewall

so go to settings >> update and security >> windows security >> firewall & network Protection. >> advanced settings.

from there do inbound rules >> new rule >> Port and then press next

1.select TCP

2 select Specific local ports

3.Enter your server port number you see when trying to make a server

4. select allow the connection First option

5. keep all boxes checked for "When does this rule apply"

name it RCT2TCU (or whatever)

Repeat those steps under the outbound Rule (Unknown if it's actually needed but it's nice to have)

Load up openRCT2.exe and hope it works.

.

.

.

.

(This Worked for me in combination with Option 3) my second theory is to go into bitdefender if you have it

go to bitdefender << protection << (Under firewall tab) Settings << add rule

1. Select Apply this rule to all applications

2. Select the advanced tab

3. turn Custom local address on

4. enter your port number you get from creating a server in the Port(s) area

5. turn Custom Remote address on

6. enter your port number you get from creating a server in the Port(s) area

press okay and itll be "opened" or atleast able to get through your firewall

.

.

.

.

my third option is the weirdest but easiest to do and you should be checking this anyway

1.open your task manager (Ctrl+Alt+Del)

2.Look through you Background Processes for OpenRCT2

3.End every OpenRCT2 process you might have open

After doing this option 3, combined with option 2 it should allow you to make the server

My guess is if one process is running in the background already it will Block the port from being used again so always end these if you don't have a dedicated server or wanna start your server.

.

.

.

.

my last option is to open the port on your router, and this should be done if it isn't already

go to your router home

in the web address bar type 192.168.1.1 (or whatever your default router address is) and the login will always be this

User: admin      or     User: password & Pass: password

Pass: password       

once logged on, and in my case i have a netgear genie, so i have to go to my Advanced tab >> Advanced setup >> Port Forwarding / Port Triggering

then i do add custom service/port

keep it as a TCP/UDP

Your External Starting port should match your External Ending port

so 11753 or whatever

Use the same port range for internal ports

then i have my internal IP address set to a random one,

but it ends with .20

 

These are just things ive been super frustrated with and feel that have contributed to me being able to have a working server. 

DEFINITELY CLOSE YOUR BACKGROUND openRCT2 PROCESSES IVE HAD SERVERS WORK ONE NIGHT THEN NOT THE NEXT. AFTER ENDING THE openRCT2 PROCESSES AND LOADING UP openRCT2 AGAIN YOU SHOULD HAVE REPEAT SUCCESS AS LONG AS THE GAME CAN GET THROUGH YOUR FIREWALL AND YOU CONTINUALLY CLEAR THE EXCESS openRCT2 Processes.

 

 

 

Hopefully this helps more than the wiki for this problem does, cause i cant get the wiki one to work either. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...