Jump to content

Running openrct2 on Fedora 24

Recommended Posts


I am having trouble getting the game to load. I am running on Fedora 24 (64 Bit)

I am sure this is a problem with my computer and not the game itself, but I was hoping someone may recognise what I need to do to get this up and running. I am pretty excited about this project :-D.

I have downloaded both the develop ( and the stable ( version of OpenRCT2.

After I gunzip and untar I try to run ./openrct with the following results:

Develop: Errors straight away: "./openrct2: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory"

Stable: The stable version opens, asks me to select my RCT Data Directory (which I do), and then it errors: "./openrct2: /lib/libcurl.so.4: no version information available (required by ./openrct2)"

I do have libcurl installed, both the i686 and the x86_64 version. If I run curl--version I receive:

curl 7.47.1 (x86_64-redhat-linux-gnu) libcurl/7.47.1 NSS/3.23 Basic ECC zlib/1.2.8 libidn/1.32 libpsl/0.13.0 (+libidn/1.32) libssh2/1.7.0 nghttp2/1.7.1
Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtsp scp sftp smb smbs smtp smtps telnet tftp 
Features: AsynchDNS IDN IPv6 Largefile GSS-API Kerberos SPNEGO NTLM NTLM_WB SSL libz HTTP2 UnixSockets Metalink PSL 


I ran through the prerequisite list on the following site to ensure I had any required packages installed. I know this is for building from source, but I figured it should therefore include everything I need to run a precompiled version.


Please let me know if there is any further useful information I could collect.

Thank you in advance for any help!

 - Matthew

Edited by Samatch
Link to comment

OpenRCT2 is still tied to 32-bit builds only for now, so make sure you have 32 bit versions of these libs installed.

The builds are prepared on a Ubuntu machine, and to get curl working on arch I needed to install compatibility package.

You can use


ldd ./openrct2

To check what libraries the binary expects.

Please document your findings and update our wiki page.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...