Jump to content
OpenRCT2
Sign in to follow this  
ieta_cassiopeia

Mechanic lost in space

Recommended Posts

While I was playing Six Flags Great Adventure, one of my mechanics got a bit lost. They ended up on a bounding box one square off the edge of the map. The mechanic was walking quite cheerfully on thin space*.

 

This was particularly impressive given that I'd allocated the mechanic a patrol area that was nowhere near the edge of the map, getting from that patrol area to the bounding box would have required crossing the park boundary, and in any case the mechanics of Rollercoaster Tycoon 2 (any version) are not noted for their swimming or spacewalking abilities (did I mention there was water in the way of this bounding box?)

 

Happily, I was able to get the mechanic out of there by simply using the manual movement tool to place the wandering mechanic near the ride that I needed to have fixed. After that, the mechanic did nothing else surprising or visibly incorrect (they didn't even do the "alternate between walking on two squares to avoid doing anything useful" quirk that's sometimes seen with the vanilla version of RCT). While this bug seems to me more amusing than problematic, I believe you are the best people to determine what should be done about this.

 

I am running OpenRCT2 of a CD copy of RCT2 with Wacky Worlds expansion. (The bug would have made far more sense had I possessed the Time Twister expansion, but I don't. I also do not have any version of RCT1 connected). It is running on Windows 7 Service Pack 1, using a game hash of 6c3c857 (version 0.26, portable installation, Windows x86 version even though my computer is 64-bit-capable). There were no warnings or other messages in the standard game indicating anything was amiss, except that the ride I was expecting this mechanic to fix wasn't getting fixed (unsurprisingly). I attempted to check on the terminal, but the terminal crashes on a white window when I try to run it.

 

The autosave is from when I noticed the problem (unfortunately I don't have one available from before the problem arose, nor do I know when it started because monitoring staff is one of the weak points of my game), the "Six Flags Great Adventure" save is from after I moved the mechanic, in case there is some comparison information between the two saves that turns out to be useful in understanding why one of my mechanics decided to practise for a NASA career on company time ;)


* - While I could imagine me getting that lost if I ever held a job requiring me to walk round a park as big as Six Flags Great Adventure, I don't think Microprose ever got round to programming characters to take on players' character traits...

Six Flags Great Adventure 2020-06-11 20-53-06.png

Six Flags Great Adventure.sv6 autosave_2020-06-11_20-46-08.sv6 Six Flags Great Adventure.sv6

Edited by ieta_cassiopeia

Share this post


Link to post

Update to state that I am going to try the latest development build (2dc98e6) to see if I can

a) replicate the issue
b) get any different information when I load the known faulty save

c) get the terminal to load.

I will update you when I have further information.

Share this post


Link to post

I have so far not been able to replicate the issue on the development build of OpenRCT.

 

The terminal SV6R file, debug replay, dump.gz file and configuration file from my attempt to interrogate the terminal have been included. I also have an 11.2 MB full dump file if that is of use to anyone. Nothing appeard on the terminal after loading the affected save file.

 

NateTheDBA, please could you include an example affected save and a screenshot, as this may help the resolvers see patterns in what is going on?

 

c235c05d-c11f-4dce-8913-ec3db73966cd.sv6r debug_replay.sv6r c235c05d-c11f-4dce-8913-ec3db73966cd(2dc98e6_x86).dmp.gz c235c05d-c11f-4dce-8913-ec3db73966cd.ini

Edited by ieta_cassiopeia

Share this post


Link to post

I'm also having this issue! There's one particular ride that sometimes gets repaired properly, and other times sends the mechanics off to the corner exactly where the one in your screenshot is.

I can't seem to upload anything - is it possible to post the save file here directly, or should I upload it on a hosting site and post the link?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...