Jump to content
OpenRCT2
Sign in to follow this  
Spekk

Some roller coaster carts won't render properly

Recommended Posts

Some roller coaster carts won't render properly. It only happens to a few vehicule designs and it sometimes fixes itself after restarting the game once or twice, tho that sometimes also won't work at all. It does the exact same thing with every render engine. What happens is, when the carts is in movement, the sprite will rapidly alternate between what seens to be every possible landscape tile design, may it be a flat grass tile, a rocky slope or a wooden tunnel entrance.

 

fsfffsfsfs.jpg

Edited by Spekk

Share this post


Link to post
Share on other sites

This can happen when there are more images in the objects/vehicles in the save than there are slots available. For some reason, it looks like OpenRCT2 doesn't always properly clear the slots when loading another game, which means it keeps filling up until glitches like these happen. We are aware of the issue, but not sure where the cause lies.

  • Like 1

Share this post


Link to post
Share on other sites

The issue is less likely to happen in parks that are smaller and/or have fewer items enabled (or items that require less image slots). Repeatedly loading saves (including the title sequence parks) increases the chance of this happening.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...