Jump to content
OpenRCT2

Not everything is loading


Recommended Posts

Hello,

I just installed OpenRCT2 and can't wait playing it.
But the problem is that when I load a scenario not everything is showing (buildings, paths, ...)
What did I do wrong?

I attached an example of Prisoner Island or castle idk anymore
Thanks for helping!

Cliffside Castle 2018-10-21 13-50-09.png

Cliffside Castle 2018-10-21 13-50-12.png

Cliffside Castle 2018-10-21 13-50-14.png

Link to post

You don't have the new .json objects that are required for the original objects to work. How did you install OpenRCT2?

Try using the launcher, that works better in most cases, and automatically keeps your game up-to-date.

Link to post
7 hours ago, jensj12 said:

You don't have the new .json objects that are required for the original objects to work. How did you install OpenRCT2?

If he was missing the JSON objects the park would fail to load. Invisible objects usually means that the JSON objects are present but not the corresponding vanilla objects (the JSON objects don't contain the actual sprites, they are still loaded from vanilla).

This probably means the expansion packs are not installed, because the game will not start at all without vanilla (it requires g1.dat). If it's all objects that are invisible and not just expansion objects, I would check to make sure the ObjData folder hasn't been deleted or moved.

  • Like 1
Link to post

At least _some_ files of Time Twister have to be there - the animatronics still show up, and the OP mentions having the scenario.

I'd completely remove the RCT2 installation and reinstall it. That should put all files back in the places they belong.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...