Jump to content
OpenRCT2
SilverTempest17

Game Crashes When There Are Over 2000 Guests In Park

Recommended Posts

Hi All,

I've been really getting into RCT2 recently, and absolutely love OpenRCT2. Just yesterday, I started a custom park, and the game has run perfectly smoothly (fps wise) throughout the entire time I've played. However, as soon as there were over 2000 guests in the park, my game began to crash. There would never be a drop in fps, it would just very abruptly crash. I tried to ignore it and just save often, but by 2200 guests, the game would crash within 30 seconds of opening the file.

I play the game with all the normal settings except uncapped fps (it usually hits around 80fps with a park as filled as mine is, but running with capped fps crashes too), and I wasn't playing with cheats on. I also have a few custom thrill rides by TheAmazingEarl (not sure if that could be a factor)

Anyone know the problem or know of a possible fix? Right now all I'm doing is removing guests when they hit around 2000.

Thank You!

Edited by SilverTempest17

Share this post


Link to post
Share on other sites

Does the game still crash if you remove all guests and then wait until you hit 2000+ guests again? Does the game crash (error message) or hang (not react)? Can you provide the save file? (You can upload files on this forum)

  • Like 1

Share this post


Link to post
Share on other sites
15 hours ago, jensj12 said:

Does the game still crash if you remove all guests and then wait until you hit 2000+ guests again? Does the game crash (error message) or hang (not react)? Can you provide the save file? (You can upload files on this forum)

I removed all the guests, but the game started crashing sooner, at only about 350 guests. I tried to continue playing on it after I posted my problem, saving as often as possible, and unfortunately saved right before the game crashed. Now, whenever I open the file, the game runs for about 1 second before it crashes. It wouldn't even display an error message or anything, the game would just instantly close. I did realize I was running the game on a previous release and updated it after the 1 second crashes started happening. Now, rather than the game instantly closing on that save, it hangs.

I did continue the park on the current release from an autosave before the original crashes started happening and it has been running fine (and I'm at about 3000 guests on that save now). My best guess is that the previous release had a problem with my computer, since the autosave is running fine.

Attached are both saves.

Thanks again for your help!

Mystic Timbers.sv6

Not-Crashing Mystic Timbers.sv6

Share this post


Link to post
Share on other sites

Sorry for a late response but the crashing was caused by the custom ride The Zap - it crashes the game when it unloads peeps. I filed a bug report although I'm not sure if it's just a bug in the ride itself.

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, tombomp said:

Sorry for a late response but the crashing was caused by the custom ride The Zap - it crashes the game when it unloads peeps. I filed a bug report although I'm not sure if it's just a bug in the ride itself.

Thank you so much!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...