Jump to content

My openrct2 isnt updated to 0.0.6-29.


Recommended Posts

So, today this topic was posted I was going to play openrct2 launcher. I go to online and I see this:Skärmbild (7).png

As you see, my version is v0.0.6-develop build 1e6ba07 and not 0.0.6-29. And if I use stable it goes to 0.0.5 instead! Why wont my launcher use 0.0.6-29?

Link to post

Your network version is 0.0.6-30, as shown underneath the server list. The server version is 0.0.6-29. The launcher updates automatically to the latest develop build, so you are ahead of the server. You need to either revert to an older version, or wait for the server to update.

 

2 hours ago, Hoodiebud said:

And if I use stable it goes to 0.0.5 instead

Yes because the version number of the latest stable build is always one behind develop. When the next stable build is released it will be 0.0.6 and develop will move to 0.0.7.

  • Like 2
Link to post

It sounds like you were looking at this:

IDNumber.PNG

This isn't the information you want. What this describes is the version, whether it's develop or stable, and the build number (written in hexadecimal.)

What you want to look for is this:

CorrectID.PNG

This is what shows you what network version you are on. It's located at the bottom-right hand corner of the multiplayer menu.

  • Like 1
Link to post
25 minutes ago, Hoodiebud said:

How do I see what exact software version I have? When I check it doesn't look like number.number.number-number and instead like number.number.number develop-build and some letters. 

The sequence of numbers and letters that appear after the "develop-build" is the commit hash. That tells you exactly what version you're on, and is updated every time anything changes. However, it's not necessary to have exactly the same version as the server to connect, you only need to have the same network version, which is not updated every commit (only those that modify the network code). Your network version is displayed underneath the server list, and the network version of the server can be viewed if you hover over the colored circle.

  • Like 1
Link to post
2 hours ago, X7123M3-256 said:

you only need to have the same network version, which is not updated every commit (only those that modify the network code).

It's updated for every change that changes the behaviour of the game, which is not network specific. For example, there was a commit a few days ago that changes when paths get connected when build. If the version number wouldn't be updated, then that would result in different results for the client and server, even though their network version would be the same.

Edited by Broxzier
  • Like 2
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...