Jump to content
OpenRCT2
Sign in to follow this  
EternalSummer247

Can Only Use One Vehicle Type

Recommended Posts

Hey guys,

So, this happens with every version I download, but I'm on 0.0.5.0 build 40253a7.

I create a scenario that has multiple vehicle types available for coasters, but when I build the coaster, only one vehicle type is available and there's no drop down to select other types. Anyone else have this problem?

I tried taking screen shots, but they're not saving for some reason... 

J

Share this post


Link to post

Are they the same coaster?

Did you setup the inventions list properly?

Have you tried using the "Enable all ride vehicles" cheat?

Share this post


Link to post
22 minutes ago, imlegos said:

Are they the same coaster?

Did you setup the inventions list properly?

Have you tried using the "Enable all ride vehicles" cheat?

Yes, I checked all types of wooden coasters and all inventions ready at start. I try not to check "Enable all ride vehicles" cheat, because I don't want the game to crash. Besides, I shouldn't have to check that anyway if I set everything up properly for those rides, which I just double checked by creating another scenario and following all those steps.

I've found that if I don't check the first available vehicle type of Wooden Coaster, then whatever comes next in the list is the available vehicle type, with no others available.

Share this post


Link to post

It's happening with Steel Twister coasters as well. The wide cars aren't available, but the standard ones are. Also, just found it happens with Monorails and Trains. Only one choice available. I built a huge monorail only for the small monorail cars to be the only option. I hate those things :(

Share this post


Link to post

I have something similar happening. I have both suspended swinging cars and suspended swinging airplane cars in my current inventions list.

When I select a s-s coaster I one have 1 car type to select from - airplane cars. I have the same trouble with wooden coasters, only articulated is there.

If I look at the opening black dos box I have an error "ERROR src\ride\ride.c:7752 (ride_set_vehicles0]]: Invalid vehicle type". This error message occurs 9 times each time you place and open a ride to change the car type. Here are screen shots.

I didn't have a problem with B&M wing, Floorless, hyper twister wide trains or twister - corkscrew,hypercoaster - or compact inverted,Inverted shuttle,Inverted vertical shuttle.

I am currently on 0.0.5.0 build d29af84

SCR5.png

SCR6.png

Edited by CharlieP

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...