Jump to content
OpenRCT2
MidnaGamer

I can't connect to any server? (still not solved)

Recommended Posts

1 hour ago, YoloSweggLord said:

Does this also allow us to rotate entrances and exits to rides? I know it's possible with hex editing, and I was actually thinking of suggesting the ability to rotate entrances/exits. I'd check for myself but I'm not on my laptop.

This is actually the reason why I made it in the first place, but it allows for rotating other map elements too. Someone else is working (or at least trying to) on something that makes entrances and exits work properly in all directions, so that guests don't have to walk straight through.

I was thinking of creating a topic about the things you can do with the tile inspector, but there are some improvements and extra features to make for it too.

Edited by Broxzier

Share this post


Link to post
11 hours ago, X7123M3-256 said:

It's not dumb, the stable builds get behind really quickly. The last stable was released a couple of weeks ago, but since then they've added the ability to rotate objects in the tile inspector, the ability to change track types of existing rides, and numerous bugfixes.  Things are being added all the time, and if you wait for them to reach stable that means several more months of ad-hoc solutions and workarounds for features not yet implemented. IMO it's worth putting up with a few more bugs, especially as they tend to get fixed quickly anyway.

With "It's dumb" i meant it's dumb that you can use online with the unstable versions because everyone on this community uses those versions for online. It feels like they are trying to leave me behind. :(

Edited by MidnaGamer

Share this post


Link to post

The game is being developed rapidly, and even the servers running develop aren't all using compatible versions of it.

If you can't connect to the master server list, have you tried to connect directly by IP? Can you connect to a server running on your local network? Have you tried running the game with --verbose to see if it tells you why it can't connect?

Share this post


Link to post
7 hours ago, X7123M3-256 said:

The game is being developed rapidly, and even the servers running develop aren't all using compatible versions of it.

If you can't connect to the master server list, have you tried to connect directly by IP? Can you connect to a server running on your local network? Have you tried running the game with --verbose to see if it tells you why it can't connect?

How do I run it with --verbose? May aswell give it a try to see if it gives anymore information at least.

Edited by Chappy258

Share this post


Link to post

It's command line option, you type --verbose after the executable name when you invoke the program. It enables more detailed logging and sometimes produces more detailed error messages. Or it may not help at all, but it's usually the first thing I try if something isn't working.

Share this post


Link to post

To do so open command prompt and navigate to the folder where openrct2.exe is located, then type "openrct2.exe --verbose"

Share this post


Link to post

Greetings,

i got the same problem on my server since around 6 months. Starting from a random day the server didn't show up at the Masterserver List anymore without changing anything on my system. First i thought it's just a small bug which will be fixed with the upcoming releases but it won't. It's still present and for that reason i began researching and analysing until i saw i'm not alone.

 

Basic facts:

Operating System: Windows Server 2012 R2

- oRCT running headless via batch (d:\programme\server\openrct2\openrct2.exe host C:\Users\Administrator\Documents\OpenRCT2\save\xxx.sv6 --port xxxxx --headless --verbose --password=xxxxx)

- IPv6 is activated and has to be activated on the server

- Port forwarding is working well, we played with manual connection the last months

- outbound traffic is free

- Serverlist stays empty, advertising won't work

 

fun fact - advertising and fetching is working fine from my workstation (Win10, IPv6 deactivated)

 

I've also tryed deactivating IPv6 for a test on my server, no cure.

Tryed to take a look into console without success. --console won't work anymore and ^-console won't give out any informations about the connection issue.

 

So, who want's to help finding the failure? Maybe we'll find the reason which could also be the reason for the others here having trouble with contacting the master server. :-)

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...